어떤 우분투 OS 버전을 사용 하는? 그것은 내 우분투에서 작동 16.04 시스템. 빠른 응답 주셔서 감사합니다! 이 서버 (우분투 12.04.5 LTS)에서 php 7.0을 업그레이드 할 수있는 방법이 있습니까? 여러 PHP 버전을 설치하였고 기본값과 다르게 사용하려는 경우. 다음 단계를 사용하여 php5.6 버전과 php7.3 버전 간에 전환할 수 있습니다. 다른 PHP 버전에 대해 동일한 명령을 사용할 수 있습니다. 안녕하세요 친구 나는 실행 및 업데이트를 해결할 수 있었다,하지만 5.6을 설치할 때 그것을 찾을 수 없습니다 … PHP 5에 대한 지원이 있는 문제를 정확히 파악하는 데 도움이 될 수 있는 몇 가지 결과를 추가하면 2019년 1월 10일부터 중단되었습니다.7로 업그레이드하는 것을 고려해 보십시오. PHP 개발 팀은 PHP 5.6.40의 즉각적인 가용성을 발표합니다. 보안 릴리스입니다. 이 릴리스에서는 몇 가지 보안 버그가 수정되었습니다. 모든 PHP 5.6 사용자는 이 버전으로 업그레이드하는 것이 좋습니다. . [이메일 보호]:~$ sudo apt 설치 php5.6 읽기 패키지 목록 … 완료 건물 종속성 트리 읽기 상태 정보…

다음 추가 패키지가 설치됩니다 : 아파치2 아파치2-빈 아파치2-데이터 apache2-utils libapache2-mod-php5.6 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.. 1-0 libssl1.0.2 php-common php5.6-pp5.6-common php5.6-json php5.6-opcache php5.6-readline 추천 패키지: 아파치2-doc 아파치2-suexec-pristine | apache2-suexec-custom php-pear 다음과 같은 새로운 패키지가 설치될 예정입니다: 아파치2-빈 아파체코2-데이터 아파치2-유틸리티 libapache2-mod-php5.6 libaprutil1 libaprutil1-dbd-sqlite3 aprutil1-ldap liblua5.1-0 libssl1.0.2 php-common php5.6 php5.6-cli php5.6-common php5.6-json php5.6-opcache php5.6-opcache php5.6-read0 0 업그레이드, 18 새로 설치, 0을 제거하고 415는 업그레이드되지 않습니다. 아카이브의 8,458 kB를 얻을 필요가있다. 이 작업 후에는 26.0MB의 추가 디스크 공간이 사용됩니다. 계속하시겠습니까? [Y/n] 다음 명령 집합을 사용하여 우분투 시스템에서 PHP 5.6에 대한 PPA를 활성화하고 PHP 5.6을 설치합니다. 이 PPA는 더 이상 우분투 12.04 수명 버전의 끝을 지원하지 않습니다. DPKG -l와 함께 설치된 PHP 패키지를 나열 | 그레프 php | awk `{print $2}` | tr “n” ” 다음 sudo 적성 제거 your_packages_here 불필요한 패키지를 제거하거나 직접 그들 모두를 제거하려는 경우 : 나는 php7을 지원하지 않는 Drupal 7 프로젝트에서 작업하고 있기 때문에 php5 (5.6)를 사용해야합니다. 문제는 내가 최근에 더 이상 php5를 지원하지 않는 것 같다 우분투 16.04 Xenial로 업데이트입니다. PPA를 추가할 수 없습니다: `ppa:~ondrej/우분투/php`. 오류: `~ondrej` 사용자 또는 팀이 없습니다. 일단 유랑과 가상 상자가 설치되면, 그것은 실행으로 쉽게 : 당신은 지금 수동으로 아파치, php 및 mysql을 설치할 수 있습니다. 입력할 때 자습서를 시도할 수 있도록 프로비저닝 구성을 정의할 수도 있습니다.

업그레이드하기 전에 모든 데이터를 백업해야 합니다. PHP 5.5에서 업그레이드하는 사용자의 경우 5.5에서 5.6.0 사이의 변경 내용을 자세히 설명하는 전체 마이그레이션 가이드를 사용할 수 있습니다. 나는 설치를 수행하려고하고 저장소 명령을 실행하는 시간에 나는 ENTER를 누른 후 오류가 당신은 심지어 동시에 두 버전을 사용하는 데 도움이 유랑 (또는 유사한 기술)을 사용하는 것을 고려할 수 있습니다. Vagrant는 본질적으로 프로젝트 기반 구성으로 VM의 위아래로 빠르고 쉽게 회전할 수 있도록 설계된 VM 클라이언트입니다. 즉, 프로젝트에 맞게 VM을 특별히 구성할 수 있으며 필요한 경우 각 VM은 프로젝트마다 다를 수 있습니다.